Page 1 of 1

Unable to Flash Crazyradio

Posted: Wed Mar 04, 2020 9:07 am
by youngbin1130

I've been trying to flash the latest version of the Crazyradio firmware using Windows Powershell but I keep getting an error. I've attached the error in this thread.

I was following the instructions from the ... ogramming/ and was able to launch into bootloader but I was unable to flash the firmware because of an error. It had worked before but I'm not sure what caused it to stop working.

I've checked my usbtools folder and the "cradio-0.53.bin" file is there so I'm not sure what's going wrong here. Also, is it a normal behavior that the CrazyRadio does not light up when it is plugged in the computer despite not having the firmware installed?

Any point to the correct direction would be great!

Re: Unable to Flash Crazyradio

Posted: Thu Mar 05, 2020 9:41 am
by tobias
I think the problem is that the "cradio-0.53.bin" needs to be in the folder you are launching python from. If it is in the usbtools folder you should run

Code: Select all

python ../usbtools/ flash usbtools/cradio-0.53.bin
The Crazyradio should light up the two leds briefly when inserted and turn of the LEDs as soon as it is enumerated.

Re: Unable to Flash Crazyradio

Posted: Fri Mar 06, 2020 9:28 am
by youngbin1130
Thanks for the reply! I was able to fix it.

However, I'm encountering consistent "Too Many Packets Lost" when the Crazyflie is around an arm length away. I've tried changing the channels for it but it yields the same result on Windows.

Re: Unable to Flash Crazyradio

Posted: Mon Mar 09, 2020 3:58 pm
by tobias
Did it work before? Possible you have flashed the "none" PA (power amplifier) version which would then give very bad radio performance.

[SOLVED] Re: Unable to Flash Crazyradio

Posted: Thu Mar 26, 2020 8:23 am
by youngbin1130
That did the trick! Thanks!

Re: [SOLVED] Re: Unable to Flash Crazyradio

Posted: Mon Mar 30, 2020 6:35 am
by christon113