Page 1 of 1

Unable to connect Crazyflie 2.0 with Crazyradio PA

Posted: Wed Mar 21, 2018 11:22 pm
by rkd
Hi there,

I have installed cfclient-win32-install-2018.01.3.exe on my windows 10 PC and followed the steps mentioned at ... /#inst-win. In the Crazyflie PC client when I click the “Scan” button in the top left corner, it never discovers Crazyflie 2.0 drone. I checked the following list before asking help here -
(1) I tried with both Crazyradio PA drivers - libusb-win32 (v. and libusbK (v. In both cases, I am able to see Crazyradio PA USB dongle in windows device manager.
(2) I can see LED displaying when I insert the Crazyradio dongle on the computer, it quickly blinks red/green upon insertion.
(3) When I click "Scan" button in PC client, I notice that red LED blinks every time in the Crazyradio dongle.
(4) I enabled ZMQ input in the config file
(5) I make sure that Crazyflie 2.0 is power-on and all LEDs are working perfectly when I do scanning on the PC client.
(6) I can see the drone on the PC the client, only if it is connected over USB.
(7) I read these posts in the developer forum - ... issues/214 ... issues/268
(8) I got tried with the message INFO:cflib.crtp.radiodriver:v0.53 dongle with serial N/A found

looking for a quick solution. Thanks!!

Re: Unable to connect Crazyflie 2.0 with Crazyradio PA

Posted: Thu Mar 22, 2018 7:37 am
by arnaud
Hi and welcome!

Thank you for the detailed description.

Everything you are doing looks right so one thing I am thinking is that your Crazyflie might be on an address which is not the default one. Maybe this Crazyflie was used by someone else before?

To verify the radio address you can connect the Crazycflie with usb, go to "connect/configure 2.0" and check the radio channel, datarate and address. It is advised to use a Datarate of 2Mbps and the default address should be 0xe7e7e7e7e7. Once you have written the default address you can try to scan again.

Re: Unable to connect Crazyflie 2.0 with Crazyradio PA

Posted: Thu Mar 22, 2018 10:21 am
by rkd
Hi arnaud,

Thanks for your prompt reply. Yeah, someone used my drone earlier. I reset those parameters as you suggested. EEhhh, it is now connected :lol: