Search found 1878 matches

by tobias
Mon May 20, 2019 12:52 pm
Forum: General discussions
Topic: CF Ignores some of the high-level commands
Replies: 10
Views: 544

Re: CF Ignores some of the high-level commands

A tricky problem, it sounds like a communication problem, like packet loss or similar but that "shouldn't" happen. If you have any way to replicate it that would help a lot.
by tobias
Fri May 17, 2019 11:07 am
Forum: Support
Topic: Flowdeck v2 failing calibration with CF 2.1
Replies: 5
Views: 492

Re: Flowdeck v2 failing calibration with CF 2.1

Please send an email to support (at) bitcraze.io and we will help you with a replacement.
by tobias
Fri May 17, 2019 11:03 am
Forum: General discussions
Topic: CF Ignores some of the high-level commands
Replies: 10
Views: 544

Re: CF Ignores some of the high-level commands

That is a bit strange. Could it be something with the battery level? Is it always between 15-20 trials or is it more random? What positioning system are you using? Thinking it could be some time related overflow or something like that.
by tobias
Fri May 17, 2019 10:58 am
Forum: Autonomous flight
Topic: Turn off z-deck on crash /tumble detection
Replies: 1
Views: 219

Re: Turn off z-deck on crash /tumble detection

The crash/tumble detection is implemented in the sitaw.c file. Is this what you are looking for?
by tobias
Mon May 06, 2019 11:37 am
Forum: Developer Discussions
Topic: flow deck outlier filter - after update to new FW version
Replies: 2
Views: 225

Re: flow deck outlier filter - after update to new FW version

Could you try to investigate a bit more about the new FW behavior? From what I know there should be no difference... The flow algorithm could probably be improved a lot, especially the error handling, so we are happy that you are trying! - did anyone try to log the motion data or the outlier filter ...
by tobias
Fri May 03, 2019 6:53 am
Forum: Developer Discussions
Topic: [SOLVED] Enabling and using the UART Rx interrupt
Replies: 4
Views: 277

Re: Enabling and using the UART Rx interrupt

I added two tests for uart1 and uart2. They are just echoing what ever you send in. I used a 3.3v FTDI cable connected to the uart signals. You could try it. You need to add the uart1test.c in the makefile and add "CFLAGS += -DDECK_FORCE=bcUart1Test" to you config.mk file.
by tobias
Thu May 02, 2019 3:21 pm
Forum: Developer Discussions
Topic: [SOLVED] Enabling and using the UART Rx interrupt
Replies: 4
Views: 277

Re: Enabling and using the UART Rx interrupt

What baudrate is the sensor. Maybe there is a miss-match in the baudrate?

I just updated the UART drivers with DMA transfer funcitons today and then the RX worked without problem.
by tobias
Tue Apr 30, 2019 2:21 pm
Forum: General discussions
Topic: GPS connection problem
Replies: 3
Views: 412

Re: GPS connection problem

As there is only experimental code using GPS can you share how you connect it and how you interface it?
by tobias
Tue Apr 30, 2019 2:19 pm
Forum: Autonomous flight
Topic: Household Autonomous Drone (Flow and Ranger Deck)
Replies: 5
Views: 521

Re: Household Autonomous Drone (Flow and Ranger Deck)

Looking forward reading about your project!
by tobias
Tue Apr 30, 2019 8:12 am
Forum: Support
Topic: Bigquad - Expansion Drone Parts Recommendations
Replies: 2
Views: 276

Re: Bigquad - Expansion Drone Parts Recommendations

I would so much like to help you but there are some many options, a bit like when building computers back in the good old days, and things move fast.