Search found 599 matches

by marcus
Thu Jun 15, 2017 8:49 am
Forum: Bitcraze
Topic: [SOLVED] 50 % more on my bill with shipping and taxes
Replies: 4
Views: 1562

Re: 50 % more on my bill with shipping and taxes

Hi Jean-Claude, I am sorry that this caused problems for you. When you buy from the Bitcraze store the goods are sent from Hong Kong. This means that when it arrives in France it is subject to VAT plus potential import duties (as stated when ordering). Unfortunately the shipping for the Crazyflie 2....
by marcus
Tue Jan 24, 2017 7:03 am
Forum: Developer Discussions
Topic: Crazyflie 2 battery charger
Replies: 7
Views: 1831

Re: Crazyflie 2 battery charger

Nice build! We've never actually put the side-by-side before so thanks for the feedback on the width. I've added an issue for the hardware so if we make a new revision we will try to slim down the board.
by marcus
Mon Jan 16, 2017 3:21 pm
Forum: Developer Discussions
Topic: Crazyflie 2 battery charger
Replies: 7
Views: 1831

Re: Crazyflie 2 battery charger

Hi,

I've just created a page on the wiki with the layout, schematic and a few pictures of the charger we built for our lab. Each charger will charge at most 500mA so if you can supply 5A you should be good. Don't forget to check the max rating of the connectors.

Let us know how it turn out!
by marcus
Wed Nov 09, 2016 9:35 am
Forum: Developer Discussions
Topic: Hover implementation
Replies: 4
Views: 1690

Re: Hover implementation

Hi,

You can add multiple logging configurations and you can start and stop them. It's not possible to do "one-shot" logging, but you can set up a logging configuration and when you get the first value back stop it.
by marcus
Mon Oct 24, 2016 11:39 am
Forum: Developer Discussions
Topic: LPS node failed to set dtr/rts
Replies: 8
Views: 3669

Re: LPS node failed to set dtr/rts

Since the DFU is working and the log from production shows output from the UART I think it's a firmware issue. It might be something wrong in the EEPROM, do you have the toolchain set up? If so then do one build where you call this function to write a default configuration to the EEPROM?
by marcus
Mon Oct 24, 2016 11:29 am
Forum: Developer Discussions
Topic: Need Help to control crazyflie 2.0 polling pitch,yaw,roll
Replies: 14
Views: 4317

Re: Need Help to control crazyflie 2.0 polling pitch,yaw,roll

Yes, you can either call stop() on the log configuration or delete() on it. The difference is that if you call stop on the log configuration it is still present in the Crazyflie 2.0 but the data stop coming. If you call delete it is removed (and the data stopps coming). There's a limited amount of l...
by marcus
Wed Oct 19, 2016 8:09 am
Forum: Developer Discussions
Topic: LPS node failed to set dtr/rts
Replies: 8
Views: 3669

Re: LPS node failed to set dtr/rts

One more thing. When Linux tries to check if the device is a modem it will send commands to it. Unfortunately some of these contain 1 and 0, which will reset the anchor address (I think the final state is 0). To make things easier you could disable this so you keep the correct anchor address and can...
by marcus
Wed Oct 19, 2016 7:59 am
Forum: Developer Discussions
Topic: LPS node failed to set dtr/rts
Replies: 8
Views: 3669

Re: LPS node failed to set dtr/rts

Hi, If the node is reset or crashes you might see something line this (got this while resetting it a few times). [ 8241.037789] cdc_acm 2-2:1.0: ttyACM3: USB ACM device [ 8244.865185] usb 2-2: USB disconnect, device number 63 [ 8244.865268] cdc_acm 2-2:1.0: failed to set dtr/rts [ 8247.449871] usb 2...
by marcus
Mon Oct 17, 2016 3:27 pm
Forum: Support
Topic: basicparam.py not changing value?
Replies: 1
Views: 818

Re: basicparam.py not changing value?

Hi,

This issue seems to be fixed in the latest commit on github (link). But I'm not really sure why reading the parameters an extra time was causing it. Needs more investigation.
by marcus
Wed Oct 12, 2016 8:22 am
Forum: Support
Topic: Why do I get Type Error exception when I run default ramp.py?
Replies: 1
Views: 718

Re: Why do I get Type Error exception when I run default ramp.py?

Hi,

Are you getting this stacktrace at the "end" of the demo? Could you copy paste the full stacktrace?