Search found 2039 matches

by tobias
Tue Sep 22, 2020 8:00 am
Forum: Quadcopters
Topic: Low output sent to M4 propeller.
Replies: 5
Views: 86

Re: Low output sent to M4 propeller.

Then next thing to investigate is the IMU, does the roll, pitch and yaw seem reasonable?
by tobias
Mon Sep 21, 2020 10:47 am
Forum: Loco Positioning System
Topic: Adoption of the DWM3000 module.
Replies: 4
Views: 349

Re: Adoption of the DWM3000 module.

Nice that the DWM3000 is available soon. They say it is pin compatible so should be a fairly easy upgrade depending on how much software changes are needed. We will try to arrange some samples our selves, thanks for the offer help though! I suggest we start by getting some samples and doing some ini...
by tobias
Mon Sep 21, 2020 9:39 am
Forum: Support
Topic: Multiranger is producing near random data
Replies: 5
Views: 130

Re: Multiranger is producing near random data

Since the VL53L1x sensor sees in a cone the distance values can jump a bit over edges but when you describe the problem I get a feeling it is something else, especially if other sensors are behaving strange as well when their distance hasn't changed. There is no special calibration needed, but dista...
by tobias
Thu Sep 17, 2020 7:46 am
Forum: Loco Positioning System
Topic: [SOLVED] Flashing a Node via SWD port
Replies: 6
Views: 101

Re: Flashing a Node via SWD port

Great that you got it solved!
by tobias
Wed Sep 16, 2020 6:59 am
Forum: General discussions
Topic: Flow Deck Access Camera
Replies: 1
Views: 42

Re: Flow Deck Access Camera

It is possible to get an image but it is very slow, takes a second or more so hard to do anything useful with it. There is code in the Arduino driver how to do it, I don't think that is in the crazyflie flow deck driver but could easily be moved there.
by tobias
Wed Sep 16, 2020 6:53 am
Forum: Loco Positioning System
Topic: [SOLVED] Flashing a Node via SWD port
Replies: 6
Views: 101

Re: Flashing a Node via SWD port

Could it be access rights problem to the st-link? Have you managed to flash the NUCLEO with the st-link?
by tobias
Wed Sep 16, 2020 6:50 am
Forum: Quadcopters
Topic: Low output sent to M4 propeller.
Replies: 5
Views: 86

Re: Low output sent to M4 propeller.

There are some parameters you can sett to enable direct control of the motor drivers. Check parameter group motorPowerSet. Then set a value between 0-65535 for the motors m1-m4. By setting enable to 1 it will activate the direct control. This way you should be able to check that the motors are outpu...
by tobias
Tue Sep 15, 2020 1:54 pm
Forum: Loco Positioning System
Topic: [SOLVED] Flashing a Node via SWD port
Replies: 6
Views: 101

Re: Flashing a Node via SWD port

I'm guessing a bit now but "open failed" might be that it can not find the file "bin/lps-node-firmware.elf" ?
by tobias
Tue Sep 15, 2020 1:49 pm
Forum: Quadcopters
Topic: Low output sent to M4 propeller.
Replies: 5
Views: 86

Re: Low output sent to M4 propeller.

If it is the same on multiple CF2.1 then I would guess it is something with the control signal. Could it be something with the controller, that is does not read around zero when the sticks are centered?
by tobias
Mon Sep 14, 2020 12:18 pm
Forum: Support
Topic: Multiranger is producing near random data
Replies: 5
Views: 130

Re: Multiranger is producing near random data

That is a bit weird. So you are saying that the blue log is showing your hand waved in front of the sensor and then you have not moved the crazyflie and the other sensors also start changing? Maybe there could be a glitch. Try pushing the multiranger while measuring to investigate if there is any gl...