Search found 10 matches

by relame
Wed Apr 21, 2021 8:26 pm
Forum: Autonomous flight
Topic: Controlling Yaw Autonomously [solved]
Replies: 6
Views: 274

Re: Controlling Yaw Autonomously

I was able to get stable yawing today with full pose messages. The issue was 100% the "LocExtQuatStdDev" value and I ended up setting it to 0.04. Its very surprising how much of an effect that value had on angles around +/- 90 degrees and how much better the UAV flies with the updated parameter. Tha...
by relame
Mon Apr 19, 2021 6:30 pm
Forum: Autonomous flight
Topic: Controlling Yaw Autonomously [solved]
Replies: 6
Views: 274

Re: Controlling Yaw Autonomously

I ended up figuring it mostly out. The GoTo command was only checking for if x, y, and z are within a tolerance and not Yaw. Right now, I can control yaw but if its anything more than a 15 degree change, it spirals out of control. I believe it to be an issue with the PID and I need to tune some of t...
by relame
Fri Apr 16, 2021 4:42 pm
Forum: Autonomous flight
Topic: Controlling Yaw Autonomously [solved]
Replies: 6
Views: 274

Re: Controlling Yaw Autonomously

Thank you for the fast response! I had my Github repository set to private and I just made it public. I believe that the Qualisys script I am using (the third link from my original post) does and adequate job at generating data from the cameras. As for the command method, I am indeed using something...
by relame
Thu Apr 15, 2021 8:32 pm
Forum: Autonomous flight
Topic: Controlling Yaw Autonomously [solved]
Replies: 6
Views: 274

Controlling Yaw Autonomously [solved]

I am very much new to crazyflie so I will try and share as much information as possible. I am currently working with a Crazyflie bolt UAV with an external Qualysis MoCap system and I am using commands like takeoff(z), goto(x,y,z,yaw) and hover(time). The X, Y and Z positions are able to be controlle...
by relame
Thu Apr 08, 2021 8:16 pm
Forum: Autonomous flight
Topic: Not enough thrust
Replies: 2
Views: 544

Re: Not enough thrust

That was exactly the issue, thank you. Specifically, my coordinate frame was flipped upside down. I thought it was an issue with the firmware but that was not the case at all.
by relame
Mon Mar 29, 2021 7:09 pm
Forum: Autonomous flight
Topic: Not enough thrust
Replies: 2
Views: 544

Not enough thrust

I am using a MoCap to receive external position data about the crazyflie but when I try to use a takeoff command, the crazyflie's motors begin to spin but they do not have enough thrust to take off. The battery is fully charged and I can fly the crazyflie with cfclient. I am wondering if there is a ...
by relame
Tue Mar 16, 2021 7:06 pm
Forum: Support
Topic: Bolt Tuning
Replies: 1
Views: 287

Bolt Tuning

I am a total beginner when it comes to drones and Crazyflie but I have been trying to tune my Crazyflie bolt with a brushless build and it is turning out to be a difficult task. I know how to adjust parameters on the firmware and upload the firmware properly and I have been testing the parameters wi...
by relame
Thu Feb 25, 2021 6:15 pm
Forum: Support
Topic: Crazyflie Bolt, one of the motor outputs is not working.
Replies: 4
Views: 550

Re: Crazyflie Bolt, one of the motor outputs is not working.

I am not sure how the signal would have been shorted to the 12V? Yes the resistor is still there and well soldered. From the picture, it is hard to tell which resistor you circled but the two outer slots of the area you circled have resistors while the middle slot does not.
by relame
Thu Feb 18, 2021 8:02 pm
Forum: Support
Topic: Crazyflie Bolt, one of the motor outputs is not working.
Replies: 4
Views: 550

Re: Crazyflie Bolt, one of the motor outputs is not working.

I also only connected the signal wires and ground wires from the bolt to the ESC. The ESC is also connected to the PDB with power and ground connections.
by relame
Thu Feb 18, 2021 7:04 pm
Forum: Support
Topic: Crazyflie Bolt, one of the motor outputs is not working.
Replies: 4
Views: 550

Crazyflie Bolt, one of the motor outputs is not working.

I just bought a brand new Crazyflie bolt and after flying a new set up for the first time, one of the outputs is not supplying proper signals to the ESC. Specifically the M1 motor outputs from the bolt have no voltage differential between outputs. The hardware I am using is as follows: 35A 2-5S Brus...