Search found 12 matches

by roeiz
Wed Oct 07, 2020 4:21 pm
Forum: Support
Topic: [SOLVED] CF won't start - EEPROM: I2C connection [FAIL].
Replies: 11
Views: 259

Re: CF won't start - EEPROM: I2C connection [FAIL].

Thanks Tobias! I was not aware I am supposed to remove the plastic cover (or that it is possible :D )
I fixed the female connectors on the crazyflie itself and it seems to have solved the issue!

Thanks a lot for the help
by roeiz
Mon Oct 05, 2020 2:38 pm
Forum: Support
Topic: [SOLVED] CF won't start - EEPROM: I2C connection [FAIL].
Replies: 11
Views: 259

Re: CF won't start - EEPROM: I2C connection [FAIL].

I can barely even see the "tongues" inside the contacts (even with a magnifying glass), so I cannot really adjust them. I'd rather soldering the male headers to the holes of the CF2, just not sure it will not hurt the CF2 in any way, and that it will fix the issue. Will it hurt the CF2 or soldering ...
by roeiz
Mon Oct 05, 2020 12:02 pm
Forum: Support
Topic: [SOLVED] CF won't start - EEPROM: I2C connection [FAIL].
Replies: 11
Views: 259

Re: CF won't start - EEPROM: I2C connection [FAIL].

Hi Tobias, thanks for the quick reply. When I remove the flow deck I am getting EEPROM: I2C connection [OK]. So I guess the I2C bus itself is still operating. Any idea what else could have gotten wrong here? My current theories are either the I2C female header connection on the CF2 itself is bad or ...
by roeiz
Mon Oct 05, 2020 9:38 am
Forum: Support
Topic: [SOLVED] CF won't start - EEPROM: I2C connection [FAIL].
Replies: 11
Views: 259

Re: CF won't start - EEPROM: I2C connection [FAIL].

Thanks Tobias. I could not follow the steps in the post you mentioned, and I have ordered a new Flow deck (this time its v2). The new flow deck had the same problem, so I soldered the pin headers to the flow deck before connecting it to the CF2. Now my CF2 won't start still gives the same failures: ...
by roeiz
Mon Sep 28, 2020 12:44 pm
Forum: Support
Topic: [SOLVED] CF won't start - EEPROM: I2C connection [FAIL].
Replies: 11
Views: 259

Re: CF won't start - EEPROM: I2C connection [FAIL].

Hi Kimberly, I've tried your suggestion and I still see the I2C failure. I guess it is worth mentioning that I am mounting a flow deck on the CF2, and now I see it is also failing its initialization. I've found this topic (written by you actually) which seems pretty similar: https://forum.bitcraze.i...
by roeiz
Fri Sep 25, 2020 3:15 pm
Forum: Support
Topic: [SOLVED] CF won't start - EEPROM: I2C connection [FAIL].
Replies: 11
Views: 259

[SOLVED] CF won't start - EEPROM: I2C connection [FAIL].

Hi, I have 2 CF2.0 bought about two years ago, which I've been working on their FW since then. Both had been through a lot (countless FW flashings, countless crashes into obstacles) and recently I've been having troubles using them. In the past month or two, whenever I've tried turning them on, ther...
by roeiz
Mon Aug 19, 2019 1:01 pm
Forum: Developer Discussions
Topic: [SOLVED] Yaw angle control (FW implementation)
Replies: 0
Views: 4248

[SOLVED] Yaw angle control (FW implementation)

Hello dear crazyfliers! I'm trying to rotate (yaw rotation that is) my crazyfly 2.0 through UART messages received from an external microcontroller. So far I was able to receive the UART messages, and even change vx, vy, z and yawRate using the setHoverSetpoint function that I've found in this post ...
by roeiz
Mon Jun 10, 2019 12:21 pm
Forum: Developer Discussions
Topic: Forcing deck initialization
Replies: 3
Views: 814

Re: Forcing deck initialization

The best would be to look in the log tab of the Crazyflie client when connecting to the Crazyflie, if a deck driver is forced it will be printed on the console. This is what I see in the client: SYS: ---------------------------- SYS: Crazyflie 2.0 is up and running! SYS: Build 69:00e0fcf022c4 (2019...
by roeiz
Sun Jun 09, 2019 3:57 pm
Forum: Developer Discussions
Topic: Forcing deck initialization
Replies: 3
Views: 814

Forcing deck initialization

Dear Bitcraze community, I was using an older VM version (ubuntu 14) and was forcing a deck initialization on the CF2. Everything worked perfectly fine, but the eclipse itself was giving me a headache due to a few bugs in the IDE. To solve the eclipse issues, I was forced to download and use the new...
by roeiz
Mon May 06, 2019 6:29 am
Forum: Developer Discussions
Topic: [SOLVED] Enabling and using the UART Rx interrupt
Replies: 4
Views: 1071

Re: [SOLVED] Enabling and using the UART Rx interrupt

Apparently I missed a baudrate define, changing it solved the issue.

Thanks Tobias! :D