Search found 6 matches

by dionigi
Thu Aug 09, 2018 6:17 pm
Forum: Developer Discussions
Topic: Debugger Problems on Native Install
Replies: 3
Views: 829

Re: Debugger Problems on Native Install

I ended up figuring it out with some more google-fu. Referencing https://forum.bitcraze.io/viewtopic.php?t=2191, I used `make DEBUG=1 CLOAD=1' and also modified the Makefile to use `OPENOCD_TARGET ?= target/stm32f4x.cfg' instead of `OPENOCD_TARGET ?= target/stm32f4x_stlink.cfg'. Lastly I double-chec...
by dionigi
Wed Aug 08, 2018 10:22 pm
Forum: Developer Discussions
Topic: Debugger Problems on Native Install
Replies: 3
Views: 829

Debugger Problems on Native Install

Hello, I'm currently trying to get the debugger working on my native install of the Crazyflie software/firmware. I'm running Ubuntu 16.04 and am able to compile all the firmware normally (meaning not for debugging purposes). I curren't am using the breakout board plus a white ST-Link/v2/ 01-0 with P...
by dionigi
Fri Jul 27, 2018 4:07 pm
Forum: Developer Discussions
Topic: Crazyflie communication
Replies: 7
Views: 1196

Re: Crazyflie communication

Should those links all be the same? In any case I'll take a look and thanks for the help!
by dionigi
Fri Jul 27, 2018 12:45 am
Forum: Developer Discussions
Topic: Crazyflie communication
Replies: 7
Views: 1196

Re: Crazyflie communication

If you work in the Crazyflie 2.0, you'll need to change crazyflie2-nrf-firmware. I think I'm getting a bit closer to getting it working, but am stuck on understanding the already written RX code in the esb.c file on crazyflie2-nrf-firmware. Based on the NRF51 spec, it appears that setting "NRF_RADI...
by dionigi
Wed Jul 25, 2018 10:23 pm
Forum: Developer Discussions
Topic: Crazyflie communication
Replies: 7
Views: 1196

Re: Crazyflie communication

This is currently not implemented in the firmware and requires some deeper changes in both NRF and STM firmwares. Basically, currently the Crazyflie is always receiving data, and the Crazyradio is always sending data (the Crazyflie can respond by attaching some payload to the Acknowledgements). For...
by dionigi
Fri Jun 22, 2018 8:17 pm
Forum: Support
Topic: Radio Not Working During Bootloader
Replies: 1
Views: 563

Radio Not Working During Bootloader

Hi all, So my radio is able to find the quadcopter through the client and when running code, but is unable to find it when I hit 'initiate cold boot' through Connect->Bootload. Of note is that I changed the address of my quadcopter from 0xE7E7E7E7E7 to 0xE7E7E7E7E8 to avoid interference from others ...